Overview:
When viewing a Call online, the Call is displaying the information from the Parent_Address_vod__c lookup field instead of the value in the Address_vod__c text field.
Root Cause:
This is working as designed.
The Address_vod__c behavior on the Page Layout online is different from the actual values on the Address_vod__c field. The UI has additional logic which controls the display of that field.
Specifically, it runs the following check: IF Parent_Address_vod__c is NOT NULL, display Parent_Address_vod__c, ELSE display Address_vod__c.
Note: The Address_vod__c on the Call object is a static stamp of the address at the time of the call. This field does not change. Parent_Address_vod__c on the Call object is not static and is updated if the Address record is updated.
A user may see a different address on a Call record if the Address record was completely changed (e.g.: updating the city, state, zip, etc.)
Solution:
It is Veeva Best Practice to create a new address record when a new address for the Health Care Provider (HCP) is available. Minor changes can be made such as: correcting spelling errors, suite numbers, etc. Major changes should be incorporated in a new Address record.
To avoid confusion by end users, it is possible to create a custom formula field on the Call Page Layout and populate the Address_vod__c values instead.
Related Documentation:
N/A
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