Overview:
When data loading records into Veeva CRM, an error occurs: Too Many SOQL queries: 101
NOTE: SOQL is defined as Sforce Object Query Language.
For example, when loading Addresses, the load errors on trigger Address_trigger_vod:
CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY:Address_trigger_vod: execution of AfterUpdate caused by: System.LimitException: Too many SOQL queries: 101 Trigger.VOD_ADDRESS_VOD_BEFORE: line 5 column 1:--
Root Cause:
The Batch size is too large.
For example, if a trigger on an object performs multiple validations against other objects, each validation may require a SOQL query. These SOQL queries are limited to 20 per invocation of the trigger.
Solution:
When data loading records into Veeva CRM, the recommend batch size needs to be followed. If additional custom triggers are created on the object, the batch size may need to be reduced.
Related Documentation:
CRM Help Documentation: Data Loading in CRM