Overview:
When viewing the My Accounts tab, many Account rows do not display Address information. This occurs even though the accounts have addresses and the user has the appropriate access to all fields and records.
Root Cause:
No Primary Address specified, or no My Preferred Address Territory Specific Field (TSF) specified.
Solution:
Address information for the My Accounts tab displays as follows:
- Display the address information for the Primary address (address where Primary_vod__c = true).
- If there is no primary account, display the account TSF My Preferred Address.
Note: If an Account only has one associated Address, it is a Best Practice to load the Address as Primary.
Related Documentation:
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