Overview:
Unable to Load Documents Greater than 5 MB from the Document Tab receiving error:
Error: This file exceeds the maximum size limit of 5 MB.
Root Cause:
This is a Salesforce limit.
Solution:
This value can be increased to a maximum value of 25 MB by opening a Case with Veeva Support. Veeva Support works with Salesforce.com to increase the limit.
Related Documentation:
Salesforce Community: Differences Between Files, Content, Knowledge, Documents, and Attachments