Overview:
The Administrator is unable to remove a record type (MCO, for example) because it is being used by the Chatter User Profile.
Root Cause:
The default Record Type needs to be removed from the Chatter Profile. This cannot be done through the UI.
Solution:
Please review the two methods below:
Method 1: Contact Veeva Support.
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Veeva Support works with Salesforce.com (SFDC) to change the default Record Type for the Chatter User Profile, which allows the ability to remove the record type.
Method 2: Manually remove the Record Type.
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Remove the Record Type using this sample link:
https://INSTANCE.salesforce.com/setup/ui/profilerecordtypeedit.jsp?id=PROFILEID&tid=OBJECT&pn=Chatter+Free+User&retURL=%2FProfileID
- Instance is the SFDC server the org is running on
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The Object is the name or ID of the object (Contact, Account or the ID of the custom object)
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The ProfileID is the ID of the profile (Chatter Free User or Chatter Moderator User as examples)
Related Documentation:
Vault Help Documentation: Deleting Default Record Type