Overview:
A user cannot see annotations on a document.
Root Cause:
The user has filtered out annotations.
Solution:
While looking at the Document in Annotation view, click on the Filter icon (which is to the right of the Note Position link). Be sure no annotations are being filtered from the document. Filters are persistent across all documents.

Note: If filters are set on one document, they are applied to all of them.
Related Documentation:
Vault Documentation: Annotating Documents
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