Overview:
A user is unable to see a Vault shared custom view.
Root Cause:
It is possible that there are more than the allowed number of views or that the user is an admin.
Solution:
A user can have a total of 100 custom views. If the user has the Share Views permission, then 200 views are possible.
Check that the View Administration permission is assigned when sharing the view. This permission allows the user who is assigned the Mandatory view the ability to change it to Non-Mandatory manually as well as modify other mandatory views available.
Also, check that the Recipients cannot remove this view from the tab's sidebar checkbox is or is not enabled.
The end-user can add the view by clicking the pencil
icon next to the Views section and add or remove the view as needed.

Thank you