Overview:
When reviewing a Presentation and using Survey functionality by API, the Survey API com.veeva.clm.getDataForCurrentObject("Presentation", "Survey_vod__c", callBack) is not returning the ID of the Survey.
Root Cause:
The Presentation record cannot display the Survey.
Solution:
- Ensure the Survey Field is filled out on the Presentation record.
- Ensure the end user has Field Level Security to the Survey Field on the Presentation Object.
- Ensure the user has record access to the Survey record.
Related Documentation:
CRM Help Documentation: Multichannel CRM / MyInsights v1.0
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