Overview:
The Vault integration user has been granted Field Level Security (FLS) to fields. But the Approved Email Administration Tab shows the fields as Hidden when viewing the Vault mapping.
Root Cause:
The Vault mapping is out of date, and the comparison has not been rerun since FLS was last changed.
Solution:
Run a comparison by clicking on View Map --> Compare CRM to Vault from the Vault Login Credential Management section of the Approved Email Administration tab.
Related Documentation:
CRM Knowledge Article: Fields Appear as Hidden in the Vault Mapping for CLM Admin in CRM