Overview:
When clicking the Manage Attendees button on a Medical Event, the page does not render the Account Lists.
Root Cause:
This problem may occur if the user does not have Field Level Security (FLS) access to the field Country_vod__c in the Address_vod__c object.
Not having this field visible prevents the building of a list of Person_Account for Events.
Solution:
Provide Field Level Security (FLS) access to the Country_vod__c field in the Address_vod__c object.
Related Documentation:
CRM Help Documentation: Adding Attendees to an Event