Overview:
Child Accounts from the Account related list (Members related list) do not match offline and online.
Root Cause:
If the total Child accounts both in and out of Territory is less than 20, the count matches the number of rows in the related list. If above 20 child accounts, the count also includes out of Territory accounts which do not display in the list.
Solution:
The related list functions differently based on the total related Child Accounts.
Related Documentation:
CRM Help Documentation: Account Hierarchy