Overview:
When trying to apply a Call Cycle from My Schedule, the search is not listing all daily calls.
Root Cause:
If labels are being used, a user can move a Call from another day. It does not copy the Label: Day_Title_vod__c.
The search results are based on Day_Title_vod__c of the Cycle Call Entry. Results are grouped by Day_of_Week_vod__c. Even though the Day of the Week column is selected, it only contains Calls that are included in the search.
Solution:
Be sure the user is searching using the Day of the Week. Or, be sure all daily Call Cycle Entries have the same Title (from the Add Label). If moving Call Cycle Entries when using labels, it is best to delete the old entry. Then, re-enter the new entry to have the label populated.
Example:
Call Cycle Entry for Henry Allen is moved from Monday (First) to Tuesday (Second):
The Second label is removed so it is not included in the search:
If the user searches by Tuesday, all calls appear:
Related Documentation:
Thank you