Overview:
Survey Admin gets Error: Invalid Data. Integration is not properly configured, please contact your administrator - when publishing a Survey on Online CRM.
Root Cause:
Survey_Publish_Apex_vod is set as 1 or Territories_vod__c field is placed on the survey page, which requires the Multichannel engine to publish it.
Solution:
To use the Multichannel engine (MC Engine) instead of a Salesforce.com (SFDC) Job:
- Survey_Publish_Apex_vod Veeva Setting is set as 1.
- Provide an admin user access to the Survey Administration tab.
- Enter and validate the integration user’s credentials.
- The integration user is used to write back data to the SFDC database after a Survey is published.
- Grant the integration user edit permission to the Survey_vod, Survey_Target_vod, and the Survey_Question_vod objects.
If Survey_Publish_Apex_vod is blank, then be sure to use Territory_vod instead of Territories_vod.