Overview:
Previous Question Response values are NOT pulled into the new Survey Target record when clicking Update Response button in Survey Target in CRM.
Root Cause:
One reason is there is inconsistency value for the answer in Question Response record.
Example:
The Question Responses for Numeric Values have Answer_Choice_vod__c = '0'
For numeric question responses, the answer for number type is stored in Number_vod__c field rather than the Answer_Choice_vod__c field. If the value is not '0' for the Answer_Choice_vod__c field, the system is unsure how to handle the '0' in Answer_Choice_vod__c field. It displays a blank value.
Solution:
Recurring Surveys display an Update Responses button when viewing a submitted Survey Target. Clicking this button creates a new Survey Target record. Previous Question Response values are pulled into the new Survey Target record unless the Survey Questions have been modified for the Survey.
Remove the inconsistency value from the relevant field.
Related Documentation:
N/A
Thank you