Overview:
Even when there are only a few accounts under specific territory node, the user still encounters the Error: Too many Accounts. Please select another Territory. - when selecting one of the territories from My Account views.
Root Cause:
The DISABLE_RM_QUERY Veeva Setting is enabled.
Solution:
In order to optimize My Accounts performance, a configuration is provided to prevent a user from selecting a territory that is three or more levels from the parent in the Territory Hierarchy. The user should select a District Manager or Sales Representative territory to proceed. If the user has access to more than 5000 accounts, it is not possible to select the All Accounts tab. This is controlled by the Veeva Setting.
Disable this setting or select an appropriate child node from the Territory Hierarchy.
Go to Setup --> Build --> Develop --> Custom Settings --> Veeva Settings --> Manage
Related Documentation:
CRM Help Documentation: My Accounts