Overview:
When taking action from the Suggestion in CRM, an error occurs: Error: {n} Call Objective/s failed to create.
Root Cause:
The error occurs because the value of the Call Objective CLM ID on the Suggestion does not match the value of Presentation ID on the CLM Presentation.
Solution:
When the error occurs, check the following:
- The user has Create permission for the Call Objective object
- When Record Type Name on the Suggestion is Call_Objective_vod, check if the Call Objective Record Type is Suggestion_vod or CLM_vod
- When the Call Objective CLM ID on the Suggestion is populated, check if it matches the Presentation ID on CLM Presentation object
- The user has Edit FLS(Field-Level Security) of the On_By_Default_vod__c field on the Call Objective object
Related Documentation:
CRM Help Documentation:
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