Overview:
When taking action from the Suggestion in CRM, an error occurs:
Error: {n} Call Objective/s failed to create. User does not have permission to update or create records for object 'Call Objective'.
Root Cause:
The error occurs because the value of the Call Objective CLM ID on the Suggestion does not match the value of Presentation ID on the CLM Presentation, the Suggestion_vod record is misconfigured, or the user does not have the appropriate permissions to perform the action.
Solution:
When the error occurs, check the following:
- Verify that the user has the following permissions:
- Create permission to the Call Objective object.
- FLS (Field Level Security) Edit permission to the Mobile_Id_vod__c field on the Call_Objective_vod object.
- FLS Edit permission to the Call_Objective_Record_Type_vod__c field on the Suggestion_vod object.
- FLS Edit permission to the On_By_Default_vod__c field on the Call Objective object.
- If the Record Type Name on the Suggestion is Call_Objective_vod, verify that the Call Objective Record Type is Suggestion_vod or CLM_vod.
- If the Call Objective CLM ID on the Suggestion is populated, verify that it matches the Presentation ID on CLM Presentation object.
-
Specify a Call Objective record type in the Call_Objective_Record_Type_vod__c field within the Suggestion_vod record.
Related Documentation:
CRM Help Documentation: