Overview:
An error message displays when uploading Survey Target records using Data Loader:
CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY:VEEVA_BEFORE_SURVEY_TARGET_UPSERT: execution of BeforeInsert caused by: System.NullPointerException: Attempt to de-reference a null object
Trigger.VEEVA_BEFORE_SURVEY_TARGET_UPSERT: line 46, column 1.
Root Cause:
A Veeva trigger needs to find the Account information in the importing file and use this Account to create a Survey Target record. If the survey target Account ID does not exist on Online CRM, the error message displays.
Solution:
Be sure the imported data is correct.
Related Documentation:
N/A