Overview:
Approved Email (AE) Documents synced successfully from Vault to CRM but are not sending. The sent email has a Status = Failed and Failure Message = "Failed to connect to Vault for validation". From the AE Admin tab, the Vault Login Credential Management user is validated.
Root Cause:
The error may occur due to incorrect Vault access or a missing Security Policy from the Vault Integration User. Emails are not sent.
Solution:
The Vault integration user has visibility to all CLM content in Vault pulled into CRM.
The Vault integration user does not have to be a System Administrator but must have Read Access to:
- Presentation and Slide Document Types
- All fields on Presentation and Slide Document Types
The Vault integration user must be assigned to a Vault Security Policy (Navigate to: Users --> Settings --> Security Policy) that has a Password Expiration value of No Expiration. If the password expires, the integration fails.
Related Documentation:
CRM Documentation: Integrating CRM and Vault for Approved Email