Overview:
Suggestion records are created in CRM Online. They do not display in CRM for iPad even though Suggestion records are downloaded to CRM for iPad by checking the local DataBase. Why are Suggestions not displaying in CRM for iPad?
Root Cause:
Suggestions do not display in CRM for iPad when any of the following conditions are met:
- The Priority_vod__c of Suggestion is empty
- The Suggestion hits the Expiration_Date_vod__c
- The Expiration_Date_vod__c is less than or equal to the Posted_Date_vod__c of the Suggestion
- The Suggestion is marked as complete, dismissed, or actioned against (for example, creating a call)
- The No_Homepage_vod__c is checked
- The Do_Not_Call_vod__c on the related Account is Yes_vod
Solution:
To display Suggestions in CRM for iPad:
- Set appropriate values to the Priority_vod__c, Expiration_Date_vod__c, and Posted_Date_vod__c of Suggestions
- Be sure the Suggestions are not marked as complete, dismissed, or actioned against
- Be sure No_Homepage_vod__c is unchecked
- Be sure the Do_Not_Call_vod__c on the related Account is not Yes_vod
Related Documentation:
CRM documentation: Suggestions Overview