Overview:
When opening a View in My Accounts in CRM Online, a warning displays:
Note: Results truncated. Please refine view.
Root Cause:
When a View is loaded in My Accounts, all unfiltered Accounts are loaded based on Account visibility and role hierarchy.
For performance reasons, this query on Accounts limits the results to 5000 or fewer account records by default on the Online platform. If the final View requires an initial, base result set of more than 5000 account records, the final results will be truncated. A warning message displays in My Accounts to indicate truncation.
This 5000 record limit is configurable and is applied only to CRM Online. The MAX_ACCT_THRESHOLD_vod Veeva Setting can be edited to raise the Accounts view limit above 5000.
NOTE: There are performance implications when raising this limit. Queries of larger sets of data take longer to return results. The decision to raise this limit should be carefully considered.
Solution:
Limit the number of Accounts to be viewed to below the Maximum Account Threshold (which is 5000 by default).
To further break down the number of Accounts returned, additional search criteria can be added to the Account object.
Related Documentation:
CRM Help Documentation: Account Lists and Views - Online
CRM Knowledge Article: How to Increase the Account View Limits in CRM Online?
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