Overview:
Duplicate answers to questions are appearing for the same user on the same non-recurring survey.
Root Cause:
Missing Create and Edit permission on the Survey Target object. This allows users to create Survey Question Response records but does not allow users to submit the Survey Target.
This can also happen if the user creates responses online, then creates responses offline, then syncs. Duplicate records can be queried against (using Mobile_ID_vod__c to differentiate) and deleted if needed.
Solution:
Permissions for the Survey_Target_vod should be set to Read, Edit, and Create. Check Field Level Security (FLS) on this object's required fields.
Related Documentation:
CRM Help Documentation: Survey Privacy Settings
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