Overview:
A user cannot edit the Product Metrics record. The following seems to be correct: all configurations, object permissions in profile, Field Level Security (FLS), Metric Config, etc.
Root Cause:
- The user territory has the setting: Users in this territory can view accounts assigned to this territory. For Account Access, the user has Read but not Edit permission on Product Metrics records.
- The issue can occur when there is no value for the field Available_Values_vod__c of the relevant Metric_Configuration_vod record.
Solution:
- Change the user Territory settings:
From: Users in this territory can view accounts assigned to this territory.
To: Users in this territory can view and edit accounts assigned to this territory.
To change this setting, open the Territory page and then change the settings for the Account Access item.
- Be sure to populate proper values for the field Available_Values_vod__c of the relevant Metric_Configuration_vod record.
Related Documentation:
- CRM Help Documentation: Displaying Product Metrics