Overview:
According to CRM online guide:
If a desired account is not listed, a user can select the Search button to open a search box. The search box allows the user to search all the person accounts in the user’s local data store (for offline platforms) or all visible accounts (for online).
The user cannot search all the person accounts when adding attendees for a call.
Root Cause:
If the Business_Professional_vod record type is enabled, the search returns only Business_Professional_vod accounts that have the same primary parent as the account.
Solution:
Disable the Business_Professional_vod record type to search all the person accounts when adding attendees for a call.
To disable the Business_Professional_vod record type:
- Navigate to Setup --> Build --> Customize --> Accounts --> Person Accounts.
- Deactivate Business_Professional_vod record type.
Related Documentation:
CRM Help Documentation: Adding Call Attendees