Overview:
A user has sufficient permissions yet still encounters the following error message when running Multichannel Cycle Plans (MCCP) Process in Online CRM: No active cycle to be processed.
Root Cause:
One reason for this error is that the related records of MCCP are not setup accordingly. For example, if there is no MC Cycle Plan Target record for a specified MC Cycle Plan, the error message occurs when running Multichannel Cycle Plans Process in Online CRM.
Another reason for the error is that the status of the MC Cycle Plan Target is not set as Active_vod.
Solution:
Create an MCCP in the following order:
- Create a Cycle.
- Create a Cycle Channel.
- Create Cycle Products.
- Create a Multichannel Cycle Plan.
- Create a Multichannel Cycle Plan Target.
- Create a Multichannel Cycle Plan Channel.
- Create a Multichannel Cycle Plan Product.
And be sure that the status of the MC Cycle Plan Target is set as Active_vod.
Related Documentation:
CRM Help Documentation: Using the Multichannel Cycle Plan Admin Console