Overview:
The value of custom phone field on Account Object are not automatically pulled into the Delivery Method picklist selection when creating a Medical Inquiry (similar to the custom email field).
Root Cause:
The Phone number field does not work the same as with email because both fax and phone delivery methods use a field type of phone. Therefore, it is not able to determine if a custom field of type phone is relevant for phone or fax delivery method.
Solution:
The phone or fax numbers, required for picklist selection, should be stored in the fields referenced in the online doc: The --anf and --anp section signals are used to allow users to enter additional values not contained within these fields.
Related Documentation:
CRM Documentation: