Overview:
- When creating contents and using the com.veeva.clm.createRecord function to save records into a custom object, an error occurs in CRM for iPad: Failed: SaveObject called with an object that cannot be accessed: <custom object name>
Root Cause:
The error occurs because the Mobile ID field is not on the custom object.
Solution:
To correct this error, add Mobile ID field to the custom object and grant Edit permission to it:
- Navigate to: Setup --> Object --> the custom object.
- In Custom Fields & Relationships, click New.
- Select Text and click Next.
- Enter Mobile ID to Field Label, 100 to Length, Mobile_ID_vod to Field Name, and enable the checkbox of Unique (case insensitive) and External ID.
- Click Next.
- Select the profiles to which the user want to grant Edit access to this field using Field Level Security. By default, all user profiles can see this field.
- Click Next again.
- Select the page layouts that should include this field.
- Click Save.
Related Documentation:
N/A
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