Overview:
After selecting the checkbox for two different Call Objectives, The Call Objective page layout is not updating to display both Call Objectives.
Example:
The Test Call Objective #1 and Test Call Objective #2 check boxes are both selected within the Call Report. The Call Objective page layout for Test Call Objective #2 displays. The Test Call Objective #1 does not display.
Root Cause:
The One Click Completion field of the Test Call Objective #1 is enabled.
If One Click Completion is checked, a Call Objective can be completed by checking the box on the Call Report. The Call Objective page layout does not display within the Call Report.
Solution:
To display the Call Objective within the Call Report, de-select the One Click Completion checkbox.
Related Documentation:
CRM Help Documentation: Call Objective Types