Overview:
If the user captures a consent for a Consent Line, it is also applied to another.
Root Cause:
The Consent Capture Engine marks Consent Lines red or green based on the available Multichannel Consent records. A comparison is made between the Record Type of the Consent Type and the Multichannel Consent record. If there are more Consent Types under a single Consent Header with the same Record Type, users may experience the described behavior.
Solution:
This setup is currently not supported. Each Consent Type under a single Consent Header should have a different Record Type.
Related Documentation:
CRM Help Documentation:
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