Overview:
Detailed Attendee Information is not displaying all of the fields listed in the Account Attendee Fields field on the Event Rule record.
Root Cause:
With the Attendee Search page, users are able to view detailed attendee information to determine valid attendees before inviting them to an Event. For example, to invite attendees whose specialty is Oncology, it is viewed in the Attendee Information section. Administrators determine which fields to display via the Event Rule with the Attendee_Fields_vod record type.
When an Event is created an Event Configuration record for the specific country and record type combination is referenced to determine everything any Event Rules this Event needs to follow. The Event Configuration record that is referenced holds the Event Rule, which lists the Account Attendee Fields. It is important that these Account Attendee Fields are accurate before an Event is created. Once the Event is created, updates to the Account Attendee Fields are not reflected in the already existing Event.
Solution:
Events are often created well in advance of adding attendees. If the Account Attendee Fields are updated on the Event Rule record after the Event is created, these are not reflected when adding Attendees. This is the most common scenario. There is no work-around for this other than creating another Event.
Another common scenario is if a double semi-colon delimited list is not being used. The proper format for the values in the Account Attendee Fields is: ;;Field Name;;Field Name;;Field Name;;. There are additional keywords that can be used: Address, LastTopic, RecentEvents, and MCCP keywords.
An example that displays the Account Identifier Field, the Specialty field, the Address field, and the RecentEvents field is shown:
;;Account_Identifier_vod;;Specialty_1_vod;;Address;;RecentEvents;;
Related Documentation:
CRM Documentation: Adding Attendees to an Event