Overview:
Send an email when creating a call in iRep but field Call2_vod__c is not populated for this sent email record after syncing to CRM Online.
Root Cause:
The profile of users does not have Field Level Security (FLS) granted to field Call2_vod__c and Related_Transaction_ID_vod__c of the Sent Email (Sent_Email_vod) Object.
Solution:
Grant FLS on fields: Call2_vod__c and Related_Transaction_ID_vod__c to users. Follow the steps to populate Call2_vod__c field:
- Log into iRep.
- Select Account.
- Select Record Call.
- Select More Actions.
- Select Send Email.
- Related_Transaction_ID_vod field is populated with the Mobile ID of the Call.
- Sync iRep.
- Wait for Approved Email Task to be executed in Veeva Process Scheduler.
- Lookup from Sent Email to Call should be populated.
Related Documentation:
CRM Help Documentation: Approved Email Entry Points
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