Overview:
Approved Emails are not being delivered. The Sent Email record has a Status of Failed with Status Details showing Failed to connect to Vault for validation.
Root Cause:
The Vault Integration User's login credentials have expired. Or, the user does not have the correct API access in Vault.
Solution:
The Vault Integration User must be assigned to a Vault Security Policy (Navigate to: Users --> Settings --> Security Policy) that has a Password Expiration value of No Expiration. If the password ever expires, the Vault integration fails.
Ensure that the Security Profile allows the Integration access to all the fields and document types. The user needs API access to all API and at least Read access to Document Fields and Document Types. The user can be set to the System Admin Security Profile or a Custom Profile with these settings.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for Approved Email