Overview:
When performing a sync with the Veeva CRM Offline, a user receives an error in the Activity log: No such column (Field API Name) on entity (Object API Name).
Root Cause:
The error occurs due to an invalid configuration. The user, who performs synchronization, does not have access to the field on the object listed. This is referenced in a WHERE clause defined in a VMobile Object Configuration (VMOC).
Solution:
Provide the user Read access to the field listed in the activity log at the Profile level or through Permission Sets.
It is recommended when making changes in the VMOC records to always check if the affected users have access to all the fields referenced in the WHERE clause.
Related Documentation:
CRM Knowledge Article: Error: No such column - Continuously Occurs With Different Fields on CRM Offline
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