Overview:
An Admin receives the error: External Users must have an email address with a different domain than the Vault customer domain when adding a user.

Root Cause:
Vault does not allow adding an external user with a Vault customer email domain.
Solution:
Use an external email address domain to add the external user.
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.