Overview:
Veeva CRM is downloaded on a Windows device from the Salesforce Org. Upon running the setup application, the following error message appears: Failed to install or update Veeva CRM application.
Root Cause:
Veeva CRM on Windows V8 and V10 deploys outside the Microsoft Windows store. In order to deploy the application, please select one of the following options:
- Enable Sideloading on the Windows devices
- Enable Developer mode in Windows.
- Deploy a Developer License on the device.
Solution:
Solution steps for each of the options:
- Enable Sideloading on the Windows device. This is covered in detail in the online documentation page for enabling Sideloading: Preparing for Deployment.
- Enable Developer mode in Windows.
- On the device to enable, go to Settings.
- Choose Update & Security.
- Select: For developers.
- Select Developer mode.
Read the Disclaimer for the setting selected, then click Yes to accept the change.

- Deploy a Developer license on the device. Obtain and manage Developer licenses at a command prompt by running these commands in Windows PowerShell:
Show-WindowsDeveloperLicenseRegistration
This command opens a dialog box from which a developer license can be obtained. Install it on the local machine. Run this command using a valid Microsoft account. Run this command in a command prompt with elevated permissions.
Get-WindowsDeveloperLicense
This command returns an object that has two properties: ExpirationTime and IsValid. ExpirationTime is a System.DateTime structure that contains the date and time when the license expires. IsValid is a System.Boolean that indicates whether the license is valid. Run this command from a command prompt that does not have elevated permissions.
Unregister-WindowsDeveloperLicense
This command warns the user that some apps stop working if the Developer license is removed from the local machine. If Yes (the default) is selected to confirm that the license is being removed, the license is removed from the local machine. Run this command in a command prompt with elevated permissions.
Note: The user must be connected to the internet to perform this.
After performing any of the steps above, run the setup again as System Administrator.
Related Documentation:
CRM Help Documentation:
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