Overview:
When editing list view columns in CRM Online, the following error appears: Unable to access page.
Root Cause:
The user is trying to modify a hard-coded list view which is called All. The list view cannot be modified.
Solution:
To resolve this error, create a custom All list view by clicking on Create New View. This overrides the hardcoded list view and allows the editing of columns.
Related Documentation:
CRM Help Documentation: Account Lists and Views