Overview:
The user cannot send the email due to an error: There are no Consent_Type_vod records applicable for this Account. Please review your Consent Capture setup.
Root Cause:
When the option Approved Email Consent Mode in the Approved Email Settings is set to 1, below two possibilities may cause this issue.
- The profile, to which the user belongs, is not configurated the Consent Capture function.
- There is no value populated in the Country field on the User record.
Solution:
The user cannot send the email with the error. The error is shown below after selecting an email template.
To resolve this error,
1. The system admin may refer to the below steps
- Navigate to: Setup --> App Setup --> Develop --> Custom Settings --> Approved Email Settings.
- Set the Approved Email Consent Mode option to 0 to resolve this problem.
2. Populate an appropriate value in the Country field on the User record.