Overview:
The Call Discussion Layout Selection is not displaying the right selection in the Call Report.
Root Cause:
The Call Discussion Layout by Record Types need to be assigned the same Record Type name of the Call Record Type name to ensure the correct Call Discussion Layout is used. When the Record Type names do not match, The Call Report Page randomly selects any Call Discussion Layout.
Solution:
The fields displayed in each product discussion section are dependent on the Record Type of the Call. To do this, create Record Types on the Call2_Discussion_vod object that have the same exact names as the Record Types on the Call2_vod object.
When a Call is created as a certain Record Type, the layout used for product discussions is the layout associated to the Record Type in the Call2_Discussion_vod object with the same name. Multiple layouts can be created for each Record Type and assigned through a Page Layout assignment to different user profiles. This allows the flexibility to display different fields to different sets of users for the same Call Record Type.
Related Documentation:
CRM Help Documentation: Defining Discussion Section Layouts By Call Record Type