Overview:
Icons for the Custom Account Record Types are not Displaying correctly on an iPad and are only showing the generic cube icon.
Root Cause:
The custom Record Type Name is used in the ACCOUNT_RECORD_TYPE_ICON_MAP Veeva Message.
Solution:
The ACCOUNT_RECORD_TYPE_ICON_MAP Veeva Message uses the untranslated Record Type Label.
If spaces are present in the Record Type Label, they must also be present in the Veeva Message.
Example:
A Custom Record Type has the untranslated label: My Custom Type and the name: My_Custom_Type. The administrator would like this record type to show the Professional_vod icon.
ACCOUNT_RECORD_TYPE_ICON_MAP contains: Professional_vod:My Custom Type
Related Documentation:
CRM Online Help: Record Types in Accounts