Overview:
An Engage Meeting is not displaying the icon to indicate who received an email invite in iRep.
Root Cause:
The picture below shows which Attendee is invited through email and which one is not invited through email.
Solution:
Engage Meeting Invites are built on top of Approved Email. The end-user needs to have Field Level Security (FLS) to the Related Transaction ID on the Sent Email Object.
Related Documentation:
CRM Help Documentation: Sending Engage Meeting Invitations via Approved Email