Overview:
When selecting the Generate Sign-In Sheet template, an error is generated - Error: Please select a template from the left hand side to see a preview. Even after selecting the template, the preview is unavailable. Further, the Generate Sign In Sheet button does not work.
Root Cause:
The preview image of the template is not created properly. This is typically caused by lack of Field Level Security (FLS). Or, the error may be caused when using a token inside of the .docx attachment on the EM Catalog record.
Solution:
The following steps can be used to troubleshoot this issue:
- Download the .docx attachment from the EM Catalog record.
- Open the .docx attachment and ensure that the syntax for the token is correct. The correct format is: {{object.fieldAPIName}}. For example, {{EM_Event_vod__c.city_vod__c}} returns the city. If there is a typo or an additional space in the token, an error occurs as shown in the screenshot.
- Once the .docx file is corrected, ensure that the end-user has visible Field Level Security for the field(s) being referenced in the token.
- Delete the .docx attachment from the EM Catalog record and re-add the .docx attachment.
- Refresh the metadata and clear cache.
After performing these steps, the preview should properly generate. The Generate Sign In Sheet button should be enabled.
Related Documentation:
CRM Documentation: Managing Event Material