Overview:
After configuring Email Receipt for Signature Transaction, the receipt records are not sending and are being placed in the saved_vod status.
Root Cause:
Object Level Security (OLS) and Field Level Security (FLS) have to be set exactly as the guide states for Email Receipt for Signature Transactions to work. This scenario occurs when a portion of the required OLS or FLS is skipped.
Solution:
Ensure the Approved Email Admin and Standard User meet the below minimum OLS for Email Receipts for Signature Transactions to work:
Email Receipts are enabled by Profile as well as by Object. For each transaction object that needs Email Receipt functionality, the end-user needs at least Edit permission. The Approved Email Admin needs at least Read permission to the following fields:
Related Documentation:
CRM Documentation: Approved Email Receipts for Signature Transactions