Overview:
After requesting a language pack be deployed to your environment custom page layouts that you have created are not translated, for example, the section headers are still in English
Root Cause:
This is expected. Veeva only deploys translations to the out of the box product.
Solution:
You can copy the translations from one of the standard page layouts to your custom layouts. Be sure to include any section headers and signals you are using in the translation.
Related Documentation:
CRM Help Documentation: CRM Guide
N/A
Thank you