Overview:
CRM Events Management (EM) Speaker YTD Caps is not reset by the scheduled apex even though it is after the reset date.
Root Cause:
The scheduled apex class Speaker_YTD_Caps_Reset only resets EM Speaker YTD Caps if the current date is the reset date. The reset date is specified using the Year_to_Date_Reset_Month_vod and Year_to_Date_Reset_Day_vod.
If the reset date is not explicitly set, the EM Speaker YTD Caps are only reset if the current date is the default date.
Solution:
This is expected functionality. The apex job should be on a recurring schedule (for example, daily) so that it runs on the reset date.
Related Documentation:
CRM Online Help: Budgets and Expenses