Problem:
Upon adding a large number of filters, the following error appears:
Your vault has experienced a network issue. Please refresh your browser and try again. If this error continues to appear, contact Veeva Support.
Root Cause:
When adding filters to a search, each distinct filter value is appended to the URL. There are also many other supporting parameters included in the URL to build out the search results page. These parameters and values can accumulate to create a request too long for the browser to handle and users will see this error in those cases. This search, or a very similar one may have worked in the past because some of the other supporting URL parameters were not present at the time the search ran successfully.
Another point to consider is that when a user saves a view, the URL is very short because the filter values are stored and represented in the URL as a single view ID. Modifying the filters after the view is loaded will unpack all of the distinct filter values and list them individually in the URL which can drive it beyond the browser limit.
Solution:
It is recommended that users manually remove filters when getting into a situation where the search is unable to run because too many filters have been applied.
Related Documentation:
Vault Help Documentation: