Problem:
Event attendees perform RSVP actions through Approved Emails but their statuses aren't updated.
Root Cause:
A very possible reason for this behavior is the misconfiguration or loss of the Approved Email-Events Management integration user.
Solution:
To resolve the issue the integration user's permissions have to checked and modified accordingly.
Note: Fixing the integration user's permissions doesn't update the statuses of Event Attendees who performed RSVP actions during the period of misconfiguration, so the statuses will have to be updated manually.
Related Documentation:
CRM Help Documentation: Using Approved Email for Events Management