Overview:
Approved Email Preview in CRM for iPad is not showing HTML that was updated in CRM Online.
Root Cause:
- Veeva HTML is what is synced over to CRM and stored in the Approved Document object. The image links are converted to fully qualified links with images being stored in the CDN.
- Veeva Preview is stored as an attachment. Veeva Preview has all the images referenced as Base 64. If the device is Offline, the images are rendered.
Solution:
Approved Email Templates must never be changed in CRM.
Vault is the 'source of truth' for email templates, and is where all changes must be made. When sending email Online, the Veeva HTML rendition is used to preview or display the email. In Offline the Veeva Preview rendition is used for the reasons mentioned above. Even if changes are made to the HTML in Approved Document record, it does not change anything in the Veeva Preview rendition.
Related Documentation:
N/A
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.