Overview:
When recording a Call and choosing a Detail Product, the corresponding Key Message does not appear in the Key Messages section.
Root Cause:
The user's language does not match the Key Message's language.
Solution:
Available Key Messages are those where the Language_vod field matches the user’s language or where Language_vod is blank on the Key Message.
Be sure that the user's language matches the language of the Key Message, or do not specify a language on the Key Message.
Related Documentation:
CRM Help Documentation: Using Key Messages on the Call Report