Overview:
In MyInsights 2.0 when the Call_Datetime_vod field is queried from the Call2_vod object in the report, all Datetime values are showing midnight.
Root Cause:
- The org is on an earlier Veeva CRM Version than the V17R3 General Release.
- The MyInsights Javascript Library version is outdated.
Solution:
Update the org to the latest Veeva CRM version.
Verify the MyInsights Javascript Library version as follows:
- Find the related HTML report with a System Administrator Online.
- Download the attached file.
- Unzip the folder and open the lib.js file in the scripts folder with a web browser.
- The MyInsights Library version number can be found on the top of the screen.
Upgrade the Library to the latest version by downloading the Javascript library from the CRM API Reference.
Related Documentation:
CRM Help Documentation: CRM API Reference - MyInsights v2.0
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.