Overview:
Multichannel Cycle Plan (MCCP) Record Types are not imported from a CRM full sandbox to Align, the Align instance has at least two CRM full sandboxes connected and all of them were created from the same production org.
Root Cause:
When CRM full Sandboxes are refreshed or created, all orgs get the same Salesforce ID's for preexisting records, including Record Types. Because of this, Align only syncs the MCCP Record Types for one of the orgs, as the CRM Record ID field should be unique.
Solution:
Create new MCCP Record Types for the affected Sandbox in CRM to have unique record type ID's in all CRM orgs.
Related Documentation:
Align Help Documentation: Targeting Planning